OpenXT 8.0.1 improperly versioned as 8.0.0. Cannot update to 9.0.0

Description

When using the Software Update feature in settings and attempting to update 8.0.1 1788 to 9.0.0 (builds 6524, 6552, others), an error is encountered:

"Installed OpenXT version: 8.0.0
Latest OpenXT version 9.0.0
It is not possible to update to this version of OpenXT"

Workaround is to change 8.0.0 to 8.0.1 within xenclient.conf to allow the install to continue.

Environment

OpenXT 8.0.1 1788

Validation Steps

  1. Install OpenXT release 8.0.1 1788

  2. Attempt to update to 9.0.0 using software update from settings

Activity

Show:
Jason Andryuk
May 20, 2019, 4:11 PM

Can we just add 8.0.0 to the stable-9 UPGRADEABLE_RELEASES? Is there a particular reason it is omitted?

Eric Chanudet
May 20, 2019, 5:22 PM

Yes, but this would leave 9.0.0 upgrade path include two versions of TBoot. It should not be a problem since almost all 8.0.0 -> 9.0.0 upgrade would be in fact 8.0.1 -> 9.0.0. Creating a step 8.0.2 would make sure of that, but again, if that is not a problem for known derivatives, I am fine with 8.0.0 -> 9.0.0 to work-around this problem.

Chris Rogers
May 20, 2019, 5:24 PM

normally I think we have users get to the latest stable-8 build before upgrading to stable-9, but from a technical perspective nothing should be blocking an upgrade from 8.0.0 if we add it to stable-9's UPGRADEABLE_RELEASES.

So either Eric cuts the 8.0.2 release or we add 8.0.0 to UPGRADEABLE_RELEASES. I'll leave it up to Eric.

Jason Andryuk
May 20, 2019, 7:29 PM

Okay, thank for the info.

Nicholas Tsirakis
June 26, 2019, 6:13 PM

OXT 8.0.0 successfully upgraded to 9.0.0. Closing.

Fixed

Assignee

Unassigned

Reporter

Andrew Jones

Labels

None

QA Assignee

Nicholas Tsirakis

QA Image URL

None

Epic Link

Components

Fix versions

Affects versions

Priority

Major
Configure